centos install flash player projector content debugger

众所周知,Adobe Flash Player 11.2将是支持Linux平台的最后一个版本,不过Google Chrome自带的Flash Player Plugin版本不受这个限制,但Adobe将继续为Flash Player 11.2 for Linux提供安全更新

Flash基础环境除了依附浏览器的Plugin版本外,还有一种Projector版本,即独立播放器程序。虽然插件版已经支持64位系统了,但播放器版本官方始终只提供32位程序包下载

下载地址(含debug版本)
http://www.adobe.com/support/flashplayer/debug_downloads.html

Linux Help(2011年11月版本)
https://helpx.adobe.com/flash-player/release-note/readme-flash-player-linux.html

文档目前只有FP9和FP10的依赖库列表说明,最新也是最后版本的FP11详情很遗憾还未更新
为了避免安装不必要的32位旧依赖库,可以通过启动时缺少库提示来按需安装,如:

由于每个人的基础环境异同需要补上的32位库也不尽相同,记得上回安装Android SDK时大规模安装过一次,可能有些依赖相同的都省了,本次最终更新列表如下:

yum完上述i686基础依赖库,剩下的就是运行时报错的解决了,相关过程如下

GTK默认加载adwaita主题警告:

GTK默认加载PackageKit模块提示:

GTK默认加载libcanberra模块提示:

运行时闪退:

运行时无声:

折腾完毕之后运行flashplayer或flashplayerdebugger一切顺利

发布者

仁杰

自由程序员

发表评论

电子邮件地址不会被公开。 必填项已用*标注